# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*source: (?!213\.211\.162\.5[567])(([0-9]{1,3}\.){3})[0-9]{1,3}"
test_str = ("source: 213.211.162.54\n"
"source: 213.211.162.55\n"
"source: 213.211.162.56\n"
"source: 213.211.162.57\n"
"source: 213.211.162.58\n"
"source: 213.211.162.59")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.