import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*source: (?!213\\.211\\.162\\.5[567])(([0-9]{1,3}\\.){3})[0-9]{1,3}";
final String string = "source: 213.211.162.54\n"
+ "source: 213.211.162.55\n"
+ "source: 213.211.162.56\n"
+ "source: 213.211.162.57\n"
+ "source: 213.211.162.58\n"
+ "source: 213.211.162.59";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}