# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\w+\W+){2})(\w)(\w*)(\w)/\1\U\2\E\3\U\4/;t' <<< "useRs may fly into JFK or laGuardia"