$re = '/((?:\w+\W+){2})(\w)(\w*)(\w)/';
$str = 'useRs may fly into JFK or laGuardia';
$subst = "\1\U\2\E\3\U\4";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;