#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?:\w+\W+){2})(\w)(\w*)(\w)"
Local $sString = "useRs may fly into JFK or laGuardia"
Local $sSubst = "\1\U\2\E\3\U\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)