use strict;
my $str = 'useRs may fly into JFK or laGuardia';
my $regex = qr/((?:\w+\W+){2})(\w)(\w*)(\w)/p;
my $subst = '\\1\\U\\2\\E\\3\\U\\4';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";