import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\w+\\W+){2})(\\w)(\\w*)(\\w)";
final String string = "useRs may fly into JFK or laGuardia";
final String subst = "\\1\\U\\2\\E\\3\\U\\4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}