package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:\w+\W+){2})(\w)(\w*)(\w)`)
var str = []byte(`useRs may fly into JFK or laGuardia`)
var substitution = []byte("\1\U\2\E\3\U\4")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}