using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\w+\W+){2})(\w)(\w*)(\w)";
string substitution = @"\1\U\2\E\3\U\4";
string input = @"useRs may fly into JFK or laGuardia";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}