#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/([\w.][\w.-]*)(?<!\/\.)(?<!\/\.\.)(?:\?.*)?$"
Local $sString = "http://site.com/." & @CRLF & _
"http://site.com/.." & @CRLF & _
"http://site.com/_" & @CRLF & _
"http://site.com/__" & @CRLF & _
"http://site.com/f" & @CRLF & _
"http://site.com/f." & @CRLF & _
"http://site.com/f.." & @CRLF & _
"http://site.com/f..." & @CRLF & _
"http://site.com/.f" & @CRLF & _
"http://site.com/..f" & @CRLF & _
"http://site.com/...f" & @CRLF & _
"http://site.com/_f" & @CRLF & _
"http://site.com/__f" & @CRLF & _
"http://site.com/f_" & @CRLF & _
"http://site.com/f__" & @CRLF & _
"http://site.com/.?x=a" & @CRLF & _
"http://site.com/..?x=a" & @CRLF & _
"http://site.com/f?x=a" & @CRLF & _
"http://site.com/f.?x=a" & @CRLF & _
"http://site.com/f..?x=a" & @CRLF & _
"http://site.com/f...?x=a" & @CRLF & _
"http://site.com/.f?x=a" & @CRLF & _
"http://site.com/..f?x=a" & @CRLF & _
"http://site.com/...f?x=a" & @CRLF & _
"http://site.com/file.name" & @CRLF & _
"http://site.com/file.name?" & @CRLF & _
"http://site.com/?file.name" & @CRLF & _
"" & @CRLF & _
"http://site.com/file_name?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name" & @CRLF & _
"" & @CRLF & _
"http://site.com/?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")