import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/([\\w.][\\w.-]*)(?<!\\/\\.)(?<!\\/\\.\\.)(?:\\?.*)?$";
final String string = "http://site.com/.\n"
+ "http://site.com/..\n"
+ "http://site.com/_\n"
+ "http://site.com/__\n"
+ "http://site.com/f\n"
+ "http://site.com/f.\n"
+ "http://site.com/f..\n"
+ "http://site.com/f...\n"
+ "http://site.com/.f\n"
+ "http://site.com/..f\n"
+ "http://site.com/...f\n"
+ "http://site.com/_f\n"
+ "http://site.com/__f\n"
+ "http://site.com/f_\n"
+ "http://site.com/f__\n"
+ "http://site.com/.?x=a\n"
+ "http://site.com/..?x=a\n"
+ "http://site.com/f?x=a\n"
+ "http://site.com/f.?x=a\n"
+ "http://site.com/f..?x=a\n"
+ "http://site.com/f...?x=a\n"
+ "http://site.com/.f?x=a\n"
+ "http://site.com/..f?x=a\n"
+ "http://site.com/...f?x=a\n"
+ "http://site.com/file.name\n"
+ "http://site.com/file.name?\n"
+ "http://site.com/?file.name\n\n"
+ "http://site.com/file_name?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name\n\n"
+ "http://site.com/?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}