import re
regex = re.compile(r"\/([\w.][\w.-]*)(?<!\/\.)(?<!\/\.\.)(?:\?.*)?$", flags=re.MULTILINE)
test_str = ("http://site.com/.\n"
"http://site.com/..\n"
"http://site.com/_\n"
"http://site.com/__\n"
"http://site.com/f\n"
"http://site.com/f.\n"
"http://site.com/f..\n"
"http://site.com/f...\n"
"http://site.com/.f\n"
"http://site.com/..f\n"
"http://site.com/...f\n"
"http://site.com/_f\n"
"http://site.com/__f\n"
"http://site.com/f_\n"
"http://site.com/f__\n"
"http://site.com/.?x=a\n"
"http://site.com/..?x=a\n"
"http://site.com/f?x=a\n"
"http://site.com/f.?x=a\n"
"http://site.com/f..?x=a\n"
"http://site.com/f...?x=a\n"
"http://site.com/.f?x=a\n"
"http://site.com/..f?x=a\n"
"http://site.com/...f?x=a\n"
"http://site.com/file.name\n"
"http://site.com/file.name?\n"
"http://site.com/?file.name\n\n"
"http://site.com/file_name?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name\n\n"
"http://site.com/?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")