using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/([\w.][\w.-]*)(?<!\/\.)(?<!\/\.\.)(?:\?.*)?$";
string input = @"http://site.com/.
http://site.com/..
http://site.com/_
http://site.com/__
http://site.com/f
http://site.com/f.
http://site.com/f..
http://site.com/f...
http://site.com/.f
http://site.com/..f
http://site.com/...f
http://site.com/_f
http://site.com/__f
http://site.com/f_
http://site.com/f__
http://site.com/.?x=a
http://site.com/..?x=a
http://site.com/f?x=a
http://site.com/f.?x=a
http://site.com/f..?x=a
http://site.com/f...?x=a
http://site.com/.f?x=a
http://site.com/..f?x=a
http://site.com/...f?x=a
http://site.com/file.name
http://site.com/file.name?
http://site.com/?file.name
http://site.com/file_name?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name
http://site.com/?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}