re = /\/([\w.][\w.-]*)(?<!\/\.)(?<!\/\.\.)(?:\?.*)?$/m
str = 'http://site.com/.
http://site.com/..
http://site.com/_
http://site.com/__
http://site.com/f
http://site.com/f.
http://site.com/f..
http://site.com/f...
http://site.com/.f
http://site.com/..f
http://site.com/...f
http://site.com/_f
http://site.com/__f
http://site.com/f_
http://site.com/f__
http://site.com/.?x=a
http://site.com/..?x=a
http://site.com/f?x=a
http://site.com/f.?x=a
http://site.com/f..?x=a
http://site.com/f...?x=a
http://site.com/.f?x=a
http://site.com/..f?x=a
http://site.com/...f?x=a
http://site.com/file.name
http://site.com/file.name?
http://site.com/?file.name
http://site.com/file_name?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name
http://site.com/?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end