import Foundation
let pattern = #"\/([\w.][\w.-]*)(?<!\/\.)(?<!\/\.\.)(?:\?.*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://site.com/.
http://site.com/..
http://site.com/_
http://site.com/__
http://site.com/f
http://site.com/f.
http://site.com/f..
http://site.com/f...
http://site.com/.f
http://site.com/..f
http://site.com/...f
http://site.com/_f
http://site.com/__f
http://site.com/f_
http://site.com/f__
http://site.com/.?x=a
http://site.com/..?x=a
http://site.com/f?x=a
http://site.com/f.?x=a
http://site.com/f..?x=a
http://site.com/f...?x=a
http://site.com/.f?x=a
http://site.com/..f?x=a
http://site.com/...f?x=a
http://site.com/file.name
http://site.com/file.name?
http://site.com/?file.name
http://site.com/file_name?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name
http://site.com/?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)