use strict;
my $str = 'http://site.com/.
http://site.com/..
http://site.com/_
http://site.com/__
http://site.com/f
http://site.com/f.
http://site.com/f..
http://site.com/f...
http://site.com/.f
http://site.com/..f
http://site.com/...f
http://site.com/_f
http://site.com/__f
http://site.com/f_
http://site.com/f__
http://site.com/.?x=a
http://site.com/..?x=a
http://site.com/f?x=a
http://site.com/f.?x=a
http://site.com/f..?x=a
http://site.com/f...?x=a
http://site.com/.f?x=a
http://site.com/..f?x=a
http://site.com/...f?x=a
http://site.com/file.name
http://site.com/file.name?
http://site.com/?file.name
http://site.com/file_name?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name
http://site.com/?file.name=abc&xxx=yyy///%%%%&z=http://site.com/?file.name
';
my $regex = qr/\/([\w.][\w.-]*)(?<!\/\.)(?<!\/\.\.)(?:\?.*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}