#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z0-9]*[a-z]+[a-z0-9]*$"
Local $sString = "8" & @CRLF & _
"123" & @CRLF & _
"1a2b3c" & @CRLF & _
"a1b2c3" & @CRLF & _
"abc123" & @CRLF & _
"123abc" & @CRLF & _
"abc" & @CRLF & _
"abc!" & @CRLF & _
"!abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")