const regex = /^[a-z0-9]*[a-z]+[a-z0-9]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9]*[a-z]+[a-z0-9]*$', 'gm')
const str = `8
123
1a2b3c
a1b2c3
abc123
123abc
abc
abc!
!abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}