import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]*[a-z]+[a-z0-9]*$";
final String string = "8\n"
+ "123\n"
+ "1a2b3c\n"
+ "a1b2c3\n"
+ "abc123\n"
+ "123abc\n"
+ "abc\n"
+ "abc!\n"
+ "!abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}