// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z0-9]*[a-z]+[a-z0-9]*$").unwrap();
let string = "8
123
1a2b3c
a1b2c3
abc123
123abc
abc
abc!
!abc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}