re = /^[a-z0-9]*[a-z]+[a-z0-9]*$/m
str = '8
123
1a2b3c
a1b2c3
abc123
123abc
abc
abc!
!abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end