package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9]*[a-z]+[a-z0-9]*$`)
var str = `8
123
1a2b3c
a1b2c3
abc123
123abc
abc
abc!
!abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}