#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\\ ](?:.[a-z]{5}|([eEdDwWaA][a-z0-9]{5}))\b"
Local $sString = "\foo" & @CRLF & _
"\123" & @CRLF & _
" 1234567890" & @CRLF & _
"\abcdefg123" & @CRLF & _
"\e12345 <--" & @CRLF & _
"\eabcde" & @CRLF & _
"\eh3geh <--" & @CRLF & _
" abcdefgs" & @CRLF & _
" 12ad3333" & @CRLF & _
" a12ad33" & @CRLF & _
"" & @CRLF & _
" eh1geh Dh3geh Ah3geh eh3geh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")