use strict;
my $str = '\\foo
\\123
1234567890
\\abcdefg123
\\e12345 <--
\\eabcde
\\eh3geh <--
abcdefgs
12ad3333
a12ad33
eh1geh Dh3geh Ah3geh eh3geh';
my $regex = qr/[\\ ](?:.[a-z]{5}|([eEdDwWaA][a-z0-9]{5}))\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}