import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\\\ ](?:.[a-z]{5}|([eEdDwWaA][a-z0-9]{5}))\\b";
final String string = "\\foo\n"
+ "\\123\n"
+ " 1234567890\n"
+ "\\abcdefg123\n"
+ "\\e12345 <--\n"
+ "\\eabcde\n"
+ "\\eh3geh <--\n"
+ " abcdefgs\n"
+ " 12ad3333\n"
+ " a12ad33\n\n"
+ " eh1geh Dh3geh Ah3geh eh3geh";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}