using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\\ ](?:.[a-z]{5}|([eEdDwWaA][a-z0-9]{5}))\b";
string input = @"\foo
\123
1234567890
\abcdefg123
\e12345 <--
\eabcde
\eh3geh <--
abcdefgs
12ad3333
a12ad33
eh1geh Dh3geh Ah3geh eh3geh";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}