import Foundation
let pattern = #"[\\ ](?:.[a-z]{5}|([eEdDwWaA][a-z0-9]{5}))\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
\foo
\123
1234567890
\abcdefg123
\e12345 <--
\eabcde
\eh3geh <--
abcdefgs
12ad3333
a12ad33
eh1geh Dh3geh Ah3geh eh3geh
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)