$re = '/[\\\\ ](?:.[a-z]{5}|([eEdDwWaA][a-z0-9]{5}))\b/m';
$str = '\\foo
\\123
1234567890
\\abcdefg123
\\e12345 <--
\\eabcde
\\eh3geh <--
abcdefgs
12ad3333
a12ad33
eh1geh Dh3geh Ah3geh eh3geh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);