// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\\ ](?:.[a-z]{5}|([eEdDwWaA][a-z0-9]{5}))\b").unwrap();
let string = "\\foo
\\123
1234567890
\\abcdefg123
\\e12345 <--
\\eabcde
\\eh3geh <--
abcdefgs
12ad3333
a12ad33
eh1geh Dh3geh Ah3geh eh3geh";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}