#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!(.*\d){5,})[a-z0-9-]+$"
Local $sString = "azv1232" & @CRLF & _
"v1v1v1v1v1v1" & @CRLF & _
"v1v1v1v1v1" & @CRLF & _
"xyzyzyzyzyzyzyzyzy" & @CRLF & _
"12345" & @CRLF & _
"1234" & @CRLF & _
"a1a1a1a1a1" & @CRLF & _
"C1234" & @CRLF & _
"C23" & @CRLF & _
"C-123" & @CRLF & _
"C1" & @CRLF & _
"1234" & @CRLF & _
"123" & @CRLF & _
"C12345" & @CRLF & _
"12345" & @CRLF & _
"C123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")