import Foundation
let pattern = #"^(?!(.*\d){5,})[a-z0-9-]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
azv1232
v1v1v1v1v1v1
v1v1v1v1v1
xyzyzyzyzyzyzyzyzy
12345
1234
a1a1a1a1a1
C1234
C23
C-123
C1
1234
123
C12345
12345
C123456
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)