use strict;
my $str = 'azv1232
v1v1v1v1v1v1
v1v1v1v1v1
xyzyzyzyzyzyzyzyzy
12345
1234
a1a1a1a1a1
C1234
C23
C-123
C1
1234
123
C12345
12345
C123456';
my $regex = qr/^(?!(.*\d){5,})[a-z0-9-]+$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}