const regex = /^(?!(.*\d){5,})[a-z0-9-]+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(.*\\d){5,})[a-z0-9-]+$', 'gmi')
const str = `azv1232
v1v1v1v1v1v1
v1v1v1v1v1
xyzyzyzyzyzyzyzyzy
12345
1234
a1a1a1a1a1
C1234
C23
C-123
C1
1234
123
C12345
12345
C123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}