import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(.*\\d){5,})[a-z0-9-]+$";
final String string = "azv1232\n"
+ "v1v1v1v1v1v1\n"
+ "v1v1v1v1v1\n"
+ "xyzyzyzyzyzyzyzyzy\n"
+ "12345\n"
+ "1234\n"
+ "a1a1a1a1a1\n"
+ "C1234\n"
+ "C23\n"
+ "C-123\n"
+ "C1\n"
+ "1234\n"
+ "123\n"
+ "C12345\n"
+ "12345\n"
+ "C123456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}