$re = '/^(?!(.*\d){5,})[a-z0-9-]+$/mi';
$str = 'azv1232
v1v1v1v1v1v1
v1v1v1v1v1
xyzyzyzyzyzyzyzyzy
12345
1234
a1a1a1a1a1
C1234
C23
C-123
C1
1234
123
C12345
12345
C123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);