import re
regex = re.compile(r"^(?!(.*\d){5,})[a-z0-9-]+$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("azv1232\n"
"v1v1v1v1v1v1\n"
"v1v1v1v1v1\n"
"xyzyzyzyzyzyzyzyzy\n"
"12345\n"
"1234\n"
"a1a1a1a1a1\n"
"C1234\n"
"C23\n"
"C-123\n"
"C1\n"
"1234\n"
"123\n"
"C12345\n"
"12345\n"
"C123456")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")