#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{12,14}"
Local $sString = "11 digit string: 12345678901" & @CRLF & _
"12 digit string: 123456789012" & @CRLF & _
"13 digit string: 1234567890123" & @CRLF & _
"14 digit string: 12345678901234" & @CRLF & _
"15 digit string: 123456789012345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")