$re = '/\d{12,14}/m';
$str = '11 digit string: 12345678901
12 digit string: 123456789012
13 digit string: 1234567890123
14 digit string: 12345678901234
15 digit string: 123456789012345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);