// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{12,14}").unwrap();
let string = "11 digit string: 12345678901
12 digit string: 123456789012
13 digit string: 1234567890123
14 digit string: 12345678901234
15 digit string: 123456789012345";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}