const regex = /\d{12,14}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{12,14}', 'gm')
const str = `11 digit string: 12345678901
12 digit string: 123456789012
13 digit string: 1234567890123
14 digit string: 12345678901234
15 digit string: 123456789012345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}