import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{12,14}";
final String string = "11 digit string: 12345678901\n"
+ "12 digit string: 123456789012\n"
+ "13 digit string: 1234567890123\n"
+ "14 digit string: 12345678901234\n"
+ "15 digit string: 123456789012345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}