using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{12,14}";
string input = @"11 digit string: 12345678901
12 digit string: 123456789012
13 digit string: 1234567890123
14 digit string: 12345678901234
15 digit string: 123456789012345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}