#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)font[^;"]+;?"
Local $sString = "В админке есть несколько текстовых полей, обрабатываемых в контроллере. На выходе — разметка, представленная строкой. Необходимо с помощью регулярки удалить из неё все свойства из атрибутов style, начинающиеся с заданной явно подстроки. Например, при заданном "font-" нужно удалить конструкции вида "font-size: 16px;", "font-weight: 400;" и т.д. Атрибут style в строке может style="font-blahblah"встречаться неоднократно."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")