$re = '/font[^;"]+;?/m';
$str = 'В админке есть несколько текстовых полей, обрабатываемых в контроллере. На выходе — разметка, представленная строкой. Необходимо с помощью регулярки удалить из неё все свойства из атрибутов style, начинающиеся с заданной явно подстроки. Например, при заданном "font-" нужно удалить конструкции вида "font-size: 16px;", "font-weight: 400;" и т.д. Атрибут style в строке может style="font-blahblah"встречаться неоднократно.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);