import Foundation
let pattern = #"font[^;"]+;?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"В админке есть несколько текстовых полей, обрабатываемых в контроллере. На выходе — разметка, представленная строкой. Необходимо с помощью регулярки удалить из неё все свойства из атрибутов style, начинающиеся с заданной явно подстроки. Например, при заданном "font-" нужно удалить конструкции вида "font-size: 16px;", "font-weight: 400;" и т.д. Атрибут style в строке может style="font-blahblah"встречаться неоднократно."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)