// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)font[^;"]+;?"#).unwrap();
let string = "В админке есть несколько текстовых полей, обрабатываемых в контроллере. На выходе — разметка, представленная строкой. Необходимо с помощью регулярки удалить из неё все свойства из атрибутов style, начинающиеся с заданной явно подстроки. Например, при заданном \"font-\" нужно удалить конструкции вида \"font-size: 16px;\", \"font-weight: 400;\" и т.д. Атрибут style в строке может style=\"font-blahblah\"встречаться неоднократно.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}