re = /font[^;"]+;?/m
str = 'В админке есть несколько текстовых полей, обрабатываемых в контроллере. На выходе — разметка, представленная строкой. Необходимо с помощью регулярки удалить из неё все свойства из атрибутов style, начинающиеся с заданной явно подстроки. Например, при заданном "font-" нужно удалить конструкции вида "font-size: 16px;", "font-weight: 400;" и т.д. Атрибут style в строке может style="font-blahblah"встречаться неоднократно.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end