using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"font[^;""]+;?";
string input = @"В админке есть несколько текстовых полей, обрабатываемых в контроллере. На выходе — разметка, представленная строкой. Необходимо с помощью регулярки удалить из неё все свойства из атрибутов style, начинающиеся с заданной явно подстроки. Например, при заданном ""font-"" нужно удалить конструкции вида ""font-size: 16px;"", ""font-weight: 400;"" и т.д. Атрибут style в строке может style=""font-blahblah""встречаться неоднократно.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}