#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(ID\:\ (?<resource_id>[a-z|\d|\ |\-]*[a-z])"
Local $sString = "module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)" & @CRLF & _
"module.kms_key.aws_kms_key.stack_key: Destruction complete after 22s" & @CRLF & _
"module.iam_profile.aws_iam_role.stack_iam_role: Destruction complete after 1s"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")