use strict;
my $str = 'module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)
module.kms_key.aws_kms_key.stack_key: Destruction complete after 22s
module.iam_profile.aws_iam_role.stack_iam_role: Destruction complete after 1s';
my $regex = qr/\(ID\:\ (?<resource_id>[a-z|\d|\ |\-]*[a-z])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}